Oculus Stability Improvements [2017_R1]

by CCP Games
Article Image

Hi Pilots,

Today we will be providing Oculus users a stability improvement - this will require users on Rift to re-update the most recent EVE: Valkyrie Wormholes patch [2017_R1]. This will not affect or change any game features across platforms.

Oculus users when loading the game may see a message concerning 'unsupported version' then it indicates that an update to the game needs to be installed. Such updates can be found by opening the Oculus Home application and looking under the Library - Updates tab.

For more information please see this help center article. If you need more information on how to update, or are experiencing technical issues with our recent update please check out this article in the EVE: Valkyrie support center and get in contact with us via a ticket if you require any assistance.

CCP Redcape